home *** CD-ROM | disk | FTP | other *** search
/ Chip 2007 January, February, March & April / Chip-Cover-CD-2007-02.iso / Pakiet bezpieczenstwa / mini Pentoo LiveCD 2006.1 / mpentoo-2006.1.iso / livecd.squashfs / var / db / pkg / dev-cpp / glibmm-2.8.1 / glibmm-2.8.1.ebuild < prev    next >
Text File  |  2006-04-20  |  1KB  |  50 lines

  1. # Copyright 1999-2006 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. # $Header: /var/cvsroot/gentoo-x86/dev-cpp/glibmm/glibmm-2.8.1.ebuild,v 1.9 2006/02/04 16:33:26 agriffis Exp $
  4.  
  5. inherit gnome2
  6.  
  7. DESCRIPTION="C++ interface for glib2"
  8. HOMEPAGE="http://gtkmm.sourceforge.net/"
  9.  
  10. LICENSE="LGPL-2.1"
  11. SLOT="2"
  12. KEYWORDS="alpha amd64 hppa ia64 ~mips ppc ppc64 sparc x86"
  13. IUSE="doc"
  14.  
  15. RDEPEND=">=dev-libs/libsigc++-2.0.11
  16.     >=dev-libs/glib-2.7"
  17.  
  18. DEPEND="${RDEPEND}
  19.     dev-util/pkgconfig
  20.     doc? ( app-doc/doxygen )"
  21.  
  22. DOCS="AUTHORS CHANGES ChangeLog NEWS README"
  23.  
  24. src_unpack() {
  25.     unpack ${A}
  26.     cd ${S}
  27.  
  28.     # don't waste time building the examples
  29.     sed -i 's/^\(SUBDIRS =.*\)examples docs\(.*\)$/\1\2/' Makefile.in || \
  30.         die "sed Makefile.in failed"
  31.  
  32.     # fix image paths
  33.     if use doc ; then
  34.         sed -i 's|../../images/||g' docs/reference/html/*.html || \
  35.             die "sed failed"
  36.     fi
  37. }
  38.  
  39. src_install() {
  40.     gnome2_src_install
  41.     rm -fr ${D}/usr/share/doc/glibmm-2.4
  42.     if use doc ; then
  43.         # API Reference
  44.         dohtml -r docs/reference/html/* docs/images/*
  45.         # examples
  46.         find examples -type d -name '.deps' -exec rm -fr {} \; 2>/dev/null
  47.         cp -R examples ${D}/usr/share/doc/${PF}
  48.     fi
  49. }
  50.